GoSquared - Errors affecting billing – Incident details

All systems operational

Errors affecting billing

Resolved
Partial outage
Started over 3 years agoLasted about 2 hours

Affected

User Accounts

Operational from 8:37 AM to 8:37 AM, Partial outage from 8:37 AM to 10:50 AM

Payments and Billing

Operational from 8:37 AM to 8:37 AM, Partial outage from 8:37 AM to 10:50 AM

Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Identified
    Identified

    Our payment provider is experiencing issues causing errors in the GoSquared billing system. Some users may experience an error message when upgrading or modifying their GoSquared subscription. If you're having any issues with your GoSquared account, please get in touch!