GoSquared - Problems with email delivery from Inbox – Incident details

All systems operational

Problems with email delivery from Inbox

Resolved
Degraded performance
Started about 7 years agoLasted about 7 hours
Updates
  • Resolved
    Resolved

    Email sending from Inbox is now working. Full functionality, including delivery status will return in the next 24 hours. Thanks for your patience while we have worked to resolve these issues.

  • Monitoring
    Monitoring

    We have corrected a problem with sending emails from Inbox and continue to monitor the situation. Emails are now being delivered successfully.

  • Investigating
    Investigating

    We're currently investigating an issue where email delivery is failing for people sending messages via email from Inbox. We'll update here as soon as we have more information to report.